Notes on EIGRP Fundamentals

each connection makes us stronger

This post will delve in to the fundamentals of EIGRP for CCNP ROUTE studies.

There are 2 types of routing protocols:

1. Link State
2. Distance Vector

EIGRP is considered a hybrid protocol.  It has characteristics of both link state and distance vector.  It behaves like a distance vector protocol because it exchanges the entire routing table with neighbors initially.  Beyond that, it behaves much more like a link state protocol (only changed routes are sent after a topology change).  It is also Cisco proprietary, which is a problem for inter-operability.

EIGRP relies on multicasting (hello packets) to 224.0.0.10 and uses RTP (reliable transport protocol) to handle the transport of messages between routers.

EIGRP supports multiple routed protocols: IP, IPX, and AppleTalk

Some basic rules when configuring EIGRP

  1. An autonomous system number is used, and only routers with the same ASN will exchange routes (become neighbors).
  2. IOS enables only EIGRP on interfaces…

View original post 921 more words

Notes on Feasibility Condition in EIGRP

each connection makes us stronger

While going back over my notes I saw that I had provided minimal information about Administrative Distance, Feasible Distance, and Feasibility Condition.  So here is a post to clarify a couple of items about this, particularly the Feasibility Condition.

As a reminder:

Advertised Distance: this is also called the Reported Distance, and this is important to know!  The concept of the AD/RD is that this is the metric as seen by the neighbor router (the router advertising the EIGRP route to you).  The Advertised Distance being sent to you is basically the neighbor routers Feasible Distance.  With each “hop” this number should goes up.  Your router will calculate a Feasible Distance, and then advertise that downstream as the Advertised Distance (or Reported Distance).  This concept is key in understanding how metrics are calculated.  Each router has to determine the cost on its own.  It uses information it knows…

View original post 284 more words

Tinkering wih RIPv2 in GNS3 v1.2

RIPv2 lab based on Sample Internetwork used for config examples in v5.0 Cert Guide by Narbiks and co (Figure 7-3, page 334):

Lab implemented on GNS3 v1.2

RIPv2

FR Switch config:

FRSwitch#show run

!
hostname FRSwitch

no ip domain lookup
ip cef
no ipv6 cef
ipv6 multicast rpf use-bgp
!
frame-relay switching

interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 102 interface Serial2/1 201
frame-relay route 112 interface Serial2/2 211
!
interface Serial2/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 201 interface Serial2/0 102
frame-relay route 401 interface Serial3/0 104
frame-relay route 601 interface Serial3/2 106
!
interface Serial2/2
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 211 interface Serial2/0 112
frame-relay route 411 interface Serial3/0 114
frame-relay route 501 interface Serial3/1 105
frame-relay route 611 interface Serial3/2 116
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 104 interface Serial2/1 401
frame-relay route 114 interface Serial2/2 411
!
interface Serial3/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 105 interface Serial2/2 501
!
interface Serial3/2
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 106 interface Serial2/1 601
frame-relay route 116 interface Serial2/2 611
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0

Router3 Config:

Router3#show run

hostname Router3
!

no ip domain lookup
ip cef
no ipv6 cef
ipv6 multicast rpf use-bgp
!
interface Ethernet0/0
ip address 172.31.103.3 255.255.255.0
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial2/0.102 multipoint
ip address 172.31.13.2 255.255.255.0
frame-relay map ip 172.31.13.1 102 broadcast
!
interface Serial2/0.112 multipoint
ip address 172.31.23.1 255.255.255.0
frame-relay map ip 172.31.23.2 112 broadcast
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!

Router4 Config:

Router4#show run

!
hostname Router4

no ip domain lookup
ip cef
no ipv6 cef
ipv6 multicast rpf use-bgp
!

interface Ethernet0/0
ip address 171.31.104.144 255.255.255.192
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial3/0.104 multipoint
ip address 172.31.14.2 255.255.255.0
frame-relay map ip 172.31.14.1 104 broadcast
!
interface Serial3/0.114 multipoint
ip address 172.31.24.1 255.255.255.0
frame-relay map ip 172.31.24.2 114 broadcast
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!

Router5 Config:

Router5#Show run

hostname Router5
!
no ip domain lookup
ip cef
no ipv6 cef
ipv6 multicast rpf use-bgp
!

interface Ethernet0/0
ip address 172.31.105.5 255.255.255.0
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial3/1.105 point-to-point
ip address 172.31.25.1 255.255.255.0
frame-relay interface-dlci 105
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!

Router6 Config:

Router6#show run

hostname Router6

!
interface Ethernet0/0
ip address 172.10.1.106 255.255.255.0
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial3/2.106 multipoint
ip address 172.31.16.6 255.255.255.0
frame-relay map ip 172.31.16.1 106 broadcast
!
interface Serial3/2.116 multipoint
ip address 10.1.26.6 255.255.255.0
frame-relay map ip 10.1.26.6 116 broadcast
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 6.6.6.6
network 172.31.0.0 0.0.255.255 area 0
network 0.0.0.0 255.255.255.255 area 0
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!

Router1 Config:

Router1#show run

hostname Router1
!

interface Ethernet0/0
ip address 172.31.11.1 255.255.255.0
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial2/1.201 multipoint
ip address 172.31.13.1 255.255.255.0
frame-relay map ip 172.31.13.2 201 broadcast
!
interface Serial2/1.401 multipoint
ip address 172.31.14.1 255.255.255.0
frame-relay map ip 172.31.14.2 401 broadcast
!
interface Serial2/1.601 multipoint
ip address 172.31.16.1 255.255.255.0
frame-relay map ip 172.31.16.6 601 broadcast
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!
ip forward-protocol nd
!

Router2 Config:

Router2#show run

hostname Router2

!
interface Ethernet0/0
ip address 172.31.11.2 255.255.255.0
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial2/2.211 multipoint
ip address 172.31.23.2 255.255.255.0
frame-relay map ip 172.31.23.1 211 broadcast
!
interface Serial2/2.411 multipoint
ip address 172.31.24.2 255.255.255.0
frame-relay map ip 172.31.24.1 411 broadcast
!
interface Serial2/2.501 point-to-point
ip address 172.31.25.2 255.255.255.0
frame-relay interface-dlci 501
!
interface Serial2/2.611 multipoint
ip address 10.1.26.6 255.255.255.0
frame-relay map ip 10.1.26.6 611 broadcast
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!

VlanSwitch Config:

VLAN1#show run
hostname VLAN1
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!

interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
shutdown
duplex auto
!
interface Ethernet1/1
shutdown
duplex auto
!
interface Ethernet1/2
shutdown
duplex auto
!
interface Ethernet1/3
shutdown
duplex auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface Vlan1
no ip address
!

Switch1 Config:

Switch1#show run
hostname Switch1
!

!
interface Loopback0
ip address 172.31.211.202 255.255.255.0
!
interface Loopback1
ip address 172.31.212.202 255.255.255.0
!
interface Loopback2
ip address 172.31.213.202 255.255.255.0
!
interface Ethernet0/0
no switchport
ip address 172.31.11.201 255.255.255.0
duplex auto
!
interface Ethernet0/1
shutdown
duplex auto
!
interface Ethernet0/2
shutdown
duplex auto
!
interface Ethernet0/3
shutdown
duplex auto
!
interface Ethernet1/0
shutdown
duplex auto
!
interface Ethernet1/1
shutdown
duplex auto
!
interface Ethernet1/2
shutdown
duplex auto
!
interface Ethernet1/3
shutdown
duplex auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 172.31.0.0
!
!

Switch2 Config:

Switch2#show run
hostname Switch2
!
!
interface Loopback0
ip address 172.31.221.202 255.255.255.0
!
interface Loopback1
ip address 172.31.222.202 255.255.255.0
!
interface Loopback2
ip address 172.31.223.202 255.255.255.0
!
interface Ethernet0/0
no switchport
ip address 172.31.11.202 255.255.255.0
duplex auto
!
interface Ethernet0/1
shutdown
duplex auto
!
interface Ethernet0/2
shutdown
duplex auto
!
interface Ethernet0/3
shutdown
duplex auto
!
interface Ethernet1/0
shutdown
duplex auto
!
interface Ethernet1/1
shutdown
duplex auto
!
interface Ethernet1/2
shutdown
duplex auto
!
interface Ethernet1/3
shutdown
duplex auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 2.2.2.2
network 172.31.0.0 0.0.255.255 area 0
network 0.0.0.0 255.255.255.255 area 0
!

Lab Tip: Absolute vs Delta

CCIE Pursuit Blog

If you’ve ever come across a RMON task in a practice lab, you probably find that the hardest part of the configuration is determining whether the value being measured is a delta (change over time) or an absolute value.  You could get the configuration completely correct except that you chose the wrong measurement option (I’ve done it plenty of times).

A recent email on the GroupStudy list defined the difference between these two modes very succinctly and very well:

Delta : For values that always increase
Absolute : For values that can increase or decrease

CPU utilization can go up or down (0% to 100%) so it would be an absolute value.  Packets entering an interface will always accumulate (until the counters are cleared) so this would be a delta value.  We’re (more likely to be*) interested in the number of packets during a certain interval (say the last 5…

View original post 147 more words

Force10 S4810 VLT – Quick Configuration sample

Hasan Mansur

.

I have already given a non-technical synopsis on VLT in one of my previous posts here http://hasanmansur.com/2012/10/15/force10-s4810-stacking-vs-vlt/

As mentioned, VLT Is a Dual Active Control Plane implementation, of a Multi System LAG. Cisco vPC is a similar technology.

VLT is beneficial in environments where the downstream devices like servers or access/distribution switches need to build port channels/LAGs across two separate upstream switches. in this context, VLT resembles what stacking offers. The other benefit is that due to distinct control planes, it is possible to perform maintenance one switch at a time without taking the entire fabric down. This is unlike stacking, where the entire fabric must be taken down for upgrades etc.

Here, i will provide a quick configuration sample on getting VLT operational between two VLT peer (S4810) switches.

.

VLT
VLT – Backup Link FTOS(conf)# interface TenGigabitEthernet 0/xx You must configure the backup link before you can…

View original post 272 more words